CRAN Package Check Results for Package MultiBD

Last updated on 2018-06-20 01:50:23 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 0.2.0 83.18 140.58 223.76 NOTE
r-devel-linux-x86_64-debian-gcc 0.2.0 68.73 106.43 175.16 NOTE
r-devel-linux-x86_64-fedora-clang 0.2.0 300.03 NOTE
r-devel-linux-x86_64-fedora-gcc 0.2.0 308.00 NOTE
r-devel-windows-ix86+x86_64 0.2.0 269.00 170.00 439.00 OK
r-patched-linux-x86_64 0.2.0 87.75 150.78 238.53 NOTE
r-patched-solaris-x86 0.2.0 45.00 ERROR
r-release-linux-x86_64 0.2.0 86.47 151.25 237.72 NOTE
r-release-windows-ix86+x86_64 0.2.0 200.00 141.00 341.00 OK
r-release-osx-x86_64 0.2.0 NOTE
r-oldrel-windows-ix86+x86_64 0.2.0 293.00 138.00 431.00 OK
r-oldrel-osx-x86_64 0.2.0 WARN

Additional issues

clang-UBSAN gcc-UBSAN

Check Details

Version: 0.2.0
Check: compiled code
Result: NOTE
    File ‘MultiBD/libs/MultiBD.so’:
     Found no calls to: ‘R_registerRoutines’, ‘R_useDynamicSymbols’
    
    It is good practice to register native routines and to disable symbol
    search.
    
    See ‘Writing portable packages’ in the ‘Writing R Extensions’ manual.
Flavors: r-devel-linux-x86_64-debian-clang, r-devel-linux-x86_64-debian-gcc, r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc, r-patched-linux-x86_64, r-release-linux-x86_64

Version: 0.2.0
Check: installed package size
Result: NOTE
     installed size is 6.1Mb
     sub-directories of 1Mb or more:
     libs 4.4Mb
Flavors: r-devel-linux-x86_64-fedora-clang, r-release-osx-x86_64, r-oldrel-osx-x86_64

Version: 0.2.0
Check: whether package can be installed
Result: ERROR
    Installation failed.
Flavor: r-patched-solaris-x86

Version: 0.2.0
Check: re-building of vignette outputs
Result: WARN
    Error in re-building vignettes:
     ...
    Warning in engine$weave(file, quiet = quiet, encoding = enc) :
     Pandoc (>= 1.12.3) and/or pandoc-citeproc not available. Falling back to R Markdown v1.
    Warning: running command 'kpsewhich framed.sty' had status 1
    Warning in test_latex_pkg("framed", system.file("misc", "framed.sty", package = "knitr")) :
     unable to find LaTeX package 'framed'; will use a copy from knitr
    Error in texi2dvi(file = file, pdf = TRUE, clean = clean, quiet = quiet, :
     Running 'texi2dvi' on 'SIRtrans.tex' failed.
    LaTeX errors:
    ! LaTeX Error: File `multirow.sty' not found.
    
    Type X to quit or <RETURN> to proceed,
    or enter new name. (Default extension: sty)
    
    ! Emergency stop.
    <read *>
    
    l.71 \usepackage
     {mathtools}^^M
    ! ==> Fatal error occurred, no output PDF file produced!
    Calls: buildVignettes -> texi2pdf -> texi2dvi
    Execution halted
Flavor: r-oldrel-osx-x86_64