CRAN Package Check Results for Package pbdDEMO

Last updated on 2018-11-24 00:51:17 CET.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 0.3-1 5.11 62.92 68.03 OK
r-devel-linux-x86_64-debian-gcc 0.3-1 5.13 55.10 60.23 OK
r-devel-linux-x86_64-fedora-clang 0.3-1 91.27 NOTE
r-devel-linux-x86_64-fedora-gcc 0.3-1 91.21 NOTE
r-devel-windows-ix86+x86_64 0.3-1 16.00 92.00 108.00 NOTE
r-patched-linux-x86_64 0.3-1 6.10 57.55 63.65 OK
r-patched-solaris-x86 0.3-1 111.80 OK
r-release-linux-x86_64 0.3-1 5.15 61.29 66.44 OK
r-release-windows-ix86+x86_64 0.3-1 12.00 90.00 102.00 NOTE
r-release-osx-x86_64 0.3-1 ERROR
r-oldrel-windows-ix86+x86_64 0.3-1 12.00 124.00 136.00 NOTE
r-oldrel-osx-x86_64 0.3-1 ERROR

Check Details

Version: 0.3-1
Check: compiled code
Result: NOTE
    File ‘pbdDEMO/libs/pbdDEMO.so’:
     Found no calls to: ‘R_registerRoutines’, ‘R_useDynamicSymbols’
    
    It is good practice to register native routines and to disable symbol
    search.
    
    See ‘Writing portable packages’ in the ‘Writing R Extensions’ manual.
Flavors: r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc

Version: 0.3-1
Check: dependencies in R code
Result: NOTE
    Not exits: C:/Program Files/netCDF 4.3.2
    Not exits: C:/Program Files/netCDF 4.3.2/bin
    Not exits: C:/Program Files/netCDF 4.3.2/deps/x64/bin
    Not exits: C:/Program Files/netCDF 4.3.2/deps/x64/bin/msvcp100.dll
    Not exits: C:/Program Files/netCDF 4.3.2/deps/x64/bin/msvcr100.dll
    Not exits: C:/Program Files/netCDF 4.3.2/deps/x64/bin/zlib.dll
    Not exits: C:/Program Files/netCDF 4.3.2/deps/x64/bin/hdf5.dll
    Not exits: C:/Program Files/netCDF 4.3.2/deps/x64/bin/hdf5_hl.dll
    Not exits: C:/Program Files/netCDF 4.3.2/bin/netcdf.dll
    ===== WARNING =====
    - netCDF 4.3.2 may not install at compile time.
    - Environment variables may not be correct at compile and run time.
    - pbdNCDF4 binary may not link with netCDF.
    - Please consider to rebuild from source.
    ===================
Flavors: r-devel-windows-ix86+x86_64, r-release-windows-ix86+x86_64, r-oldrel-windows-ix86+x86_64

Version: 0.3-1
Check: package dependencies
Result: ERROR
    Packages required but not available: ‘pbdMPI’ ‘pbdBASE’ ‘pbdDMAT’
    
    Package which this enhances but not available for checking: ‘pmclust’
    
    See section ‘The DESCRIPTION file’ in the ‘Writing R Extensions’
    manual.
Flavors: r-release-osx-x86_64, r-oldrel-osx-x86_64