CRAN Package Check Results for Package Mega2R

Last updated on 2019-01-19 00:46:32 CET.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 1.0.4 36.95 304.13 341.08 OK
r-devel-linux-x86_64-debian-gcc 1.0.4 36.12 235.76 271.88 OK
r-devel-linux-x86_64-fedora-clang 1.0.4 432.54 OK
r-devel-linux-x86_64-fedora-gcc 1.0.4 408.74 OK
r-devel-windows-ix86+x86_64 1.0.4 92.00 489.00 581.00 OK
r-patched-linux-x86_64 1.0.4 40.09 304.65 344.74 OK
r-patched-solaris-x86 1.0.4 4.10 ERROR --no-vignettes
r-release-linux-x86_64 1.0.4 42.88 303.32 346.20 OK
r-release-windows-ix86+x86_64 1.0.4 85.00 480.00 565.00 OK
r-release-osx-x86_64 1.0.4 WARN
r-oldrel-windows-ix86+x86_64 1.0.3 65.00 467.00 532.00 OK
r-oldrel-osx-x86_64 1.0.4 ERROR

Check Details

Version: 1.0.4
Flags: --no-vignettes
Check: package dependencies
Result: ERROR
    Package required but not available: ‘gdsfmt’
    
    See section ‘The DESCRIPTION file’ in the ‘Writing R Extensions’
    manual.
Flavor: r-patched-solaris-x86

Version: 1.0.4
Check: package dependencies
Result: NOTE
    Package suggested but not available for checking: ‘TxDb.Hsapiens.UCSC.hg19.knownGene’
Flavor: r-release-osx-x86_64

Version: 1.0.4
Check: re-building of vignette outputs
Result: WARN
    Error in re-building vignettes:
     ...
    Warning in engine$weave(file, quiet = quiet, encoding = enc) :
     Pandoc (>= 1.12.3) and/or pandoc-citeproc not available. Falling back to R Markdown v1.
    Loading required package: SKAT
    Loading required package: pedgene
    Loading required package: Matrix
    Loading required package: CompQuadForm
    Loading required package: survey
    Loading required package: grid
    Loading required package: survival
    
    Attaching package: 'survey'
    
    The following object is masked from 'package:graphics':
    
     dotchart
    
    Loading required package: kinship2
    Loading required package: quadprog
    Loading required package: gdsfmt
    Quitting from lines 694-696 (mega2rtutorial.Rmd)
    Error: processing vignette 'mega2rtutorial.Rmd' failed with diagnostics:
    there is no package called 'TxDb.Hsapiens.UCSC.hg19.knownGene'
    Execution halted
Flavor: r-release-osx-x86_64

Version: 1.0.4
Check: package dependencies
Result: NOTE
    Packages suggested but not available for checking:
     ‘TxDb.Hsapiens.UCSC.hg19.knownGene’ ‘org.Hs.eg.db’
Flavor: r-oldrel-osx-x86_64

Version: 1.0.4
Check: whether package can be installed
Result: ERROR
    Installation failed.
Flavor: r-oldrel-osx-x86_64