CRAN Package Check Results for Package predictoR

Last updated on 2019-03-14 00:46:51 CET.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 1.0.4 1.99 17.47 19.46 OK
r-devel-linux-x86_64-debian-gcc 1.0.4 1.50 13.86 15.36 OK
r-devel-linux-x86_64-fedora-clang 1.0.4 23.46 NOTE
r-devel-linux-x86_64-fedora-gcc 1.0.4 22.03 NOTE
r-devel-windows-ix86+x86_64 1.0.4 7.00 32.00 39.00 OK
r-patched-linux-x86_64 1.0.4 1.02 16.13 17.15 OK
r-patched-solaris-x86 1.0.4 3.70 ERROR
r-release-linux-x86_64 OK
r-release-windows-ix86+x86_64 1.0.4 7.00 55.00 62.00 OK
r-release-osx-x86_64 1.0.4 NOTE
r-oldrel-osx-x86_64 1.0.4 ERROR

Check Details

Version: 1.0.4
Check: dependencies in R code
Result: NOTE
    Namespaces in Imports field not imported from:
     ‘DT’ ‘ROCR’ ‘ada’ ‘colourpicker’ ‘corrplot’ ‘e1071’ ‘flexdashboard’
     ‘kknn’ ‘neuralnet’ ‘randomForest’ ‘rattle’ ‘rpart’ ‘scatterplot3d’
     ‘shinyAce’ ‘shinyWidgets’ ‘shinydashboardPlus’ ‘shinyjs’ ‘tidyverse’
     ‘xgboost’ ‘zip’
     All declared Imports should be used.
Flavors: r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc, r-release-osx-x86_64

Version: 1.0.4
Check: package dependencies
Result: ERROR
    Package required but not available: ‘xgboost’
    
    See section ‘The DESCRIPTION file’ in the ‘Writing R Extensions’
    manual.
Flavor: r-patched-solaris-x86

Version: 1.0.4
Check: whether package can be installed
Result: ERROR
    Installation failed.
Flavor: r-oldrel-osx-x86_64