CRAN Package Check Results for Package MixSIAR

Last updated on 2019-04-13 01:58:11 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 3.1.10 7.34 90.81 98.15 ERROR
r-devel-linux-x86_64-debian-gcc 3.1.10 6.57 73.07 79.64 OK
r-devel-linux-x86_64-fedora-clang 3.1.10 115.55 NOTE
r-devel-linux-x86_64-fedora-gcc 3.1.10 111.29 NOTE
r-devel-windows-ix86+x86_64 3.1.10 11.00 92.00 103.00 OK
r-patched-linux-x86_64 3.1.10 8.56 90.46 99.02 OK
r-patched-solaris-x86 3.1.10 124.10 NOTE
r-release-linux-x86_64 3.1.10 6.47 74.12 80.59 OK
r-release-windows-ix86+x86_64 3.1.10 14.00 108.00 122.00 OK
r-release-osx-x86_64 3.1.10 ERROR
r-oldrel-windows-ix86+x86_64 3.1.10 6.00 94.00 100.00 OK
r-oldrel-osx-x86_64 3.1.10 ERROR

Check Details

Version: 3.1.10
Check: package dependencies
Result: NOTE
    Package suggested but not available for checking: 'gWidgetsRGtk2'
Flavors: r-devel-linux-x86_64-debian-clang, r-release-osx-x86_64, r-oldrel-osx-x86_64

Version: 3.1.10
Check: examples
Result: ERROR
    Running examples in 'MixSIAR-Ex.R' failed
    The error most likely occurred in:
    
    > base::assign(".ptime", proc.time(), pos = "CheckExEnv")
    > ### Name: mixsiar_gui
    > ### Title: Run the GUI version of MixSIAR
    > ### Aliases: mixsiar_gui
    >
    > ### ** Examples
    >
    > mixsiar_gui()
    Error in mixsiar_gui() :
     *** gWidgetsRGtk2 package not able to be loaded. ***
     If 'library('gWidgetsRGtk2')' does not work, MixSIAR GUI will not run.
     On Windows/Linux, try 'install.packages('gWidgetsRGtk2')'.
     On Mac, close R, download and install GTK+ from:
     http://r.research.att.com/#other. Then install latest X11 application
     (xQuartz) from http://xquartz.macosforge.org/landing/.
    
     If installing GTK+ continues to be problematic, consider using the
     script version of MixSIAR. See manual for help and examples.
    Execution halted
Flavor: r-devel-linux-x86_64-debian-clang

Version: 3.1.10
Check: dependencies in R code
Result: NOTE
    Namespace in Imports field not imported from: ‘rjags’
     All declared Imports should be used.
Flavors: r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc, r-patched-solaris-x86, r-release-osx-x86_64, r-oldrel-osx-x86_64

Version: 3.1.10
Check: examples
Result: ERROR
    Running examples in ‘MixSIAR-Ex.R’ failed
    The error most likely occurred in:
    
    > ### Name: mixsiar_gui
    > ### Title: Run the GUI version of MixSIAR
    > ### Aliases: mixsiar_gui
    >
    > ### ** Examples
    >
    > mixsiar_gui()
    Error in mixsiar_gui() :
     *** gWidgetsRGtk2 package not able to be loaded. ***
     If 'library('gWidgetsRGtk2')' does not work, MixSIAR GUI will not run.
     On Windows/Linux, try 'install.packages('gWidgetsRGtk2')'.
     On Mac, close R, download and install GTK+ from:
     http://r.research.att.com/#other. Then install latest X11 application
     (xQuartz) from http://xquartz.macosforge.org/landing/.
    
     If installing GTK+ continues to be problematic, consider using the
     script version of MixSIAR. See manual for help and examples.
    Execution halted
Flavors: r-release-osx-x86_64, r-oldrel-osx-x86_64